i have a 2003 chrysler voyager, at first it was sputtering and dying while driving, we replaced fuel pump didnt do it again for a while then started again autozone codes said crank shaft sensor and ca

Asked by Dec 06, 2015 at 10:21 AM about the 2003 Chrysler Voyager

Question type: General

i have a 2003 chrysler voyager, at first it was sputtering and dying while
driving, we replaced fuel pump didnt do it again for a while then started again
autozone codes said crank shaft sensor and cam shaft sensor replaced those
now wont start jumped battery still wont start. ready to junk it help please has
new wires, plugs and oil change

1 Answer

27,185

Did a shop replace the cam and crank sensors? Those have to go back in precisely the same position they were in, otherwise timing will be off.

1 of 1 people found this helpful.

Your Answer

Chrysler Voyager Experts

  • #1
    darrellshirley
    Reputation
    320
  • #2
    Ronald Dake
    Reputation
    270
  • #3
    lightGear
    Reputation
    160
View All

Related Models For Sale

Used Chrysler Town & Country
270 Great Deals out of 14,094 listings starting at $1,999
Used Dodge Grand Caravan
288 Great Deals out of 26,034 listings starting at $1,500
Used Dodge Caravan
581 listings starting at $3,995
Used Chrysler Pacifica
43 Great Deals out of 30,922 listings starting at $1,500
Used Ford Mustang
593 Great Deals out of 36,388 listings starting at $899

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.