i have a 2003 ford windstar my air cond doesn't blow out the vents only the defrost back vents work

Asked by Jun 07, 2014 at 01:33 PM about the 2003 Ford Windstar

Question type: Maintenance & Repair

2 Answers

80,385

Sounds like you have a disconnected vacuum hose. There will be a vacuum hose that goes from the intake manifold back through the firewall to the control panel on the dash. It's either broken or got disconnected somehow. When the system loses vacuum it defaults to defrost for safety reasons. HTH. -Jim

6 people found this helpful.

Thank you for the info.

Your Answer:

Ford Windstar Experts

  • #1
    JohnBarJB
    Reputation
    610
  • #2
    T_S_T
    Reputation
    480
  • #3
    Tom Demyan
    Reputation
    460
View All

Related Models For Sale

Used Ford Freestar
416 listings starting at $1,995
Used Ford F-150
2,398 Great Deals out of 200,117 listings starting at $1,300
Used Honda Odyssey
475 Great Deals out of 34,925 listings starting at $1,200
Used Toyota Sienna
251 Great Deals out of 24,368 listings starting at $1,250
Used Dodge Grand Caravan
271 Great Deals out of 29,787 listings starting at $1,900
Used Chrysler Town & Country
284 Great Deals out of 12,477 listings starting at $1,999
Used Dodge Caravan
404 listings starting at $4,950
Used Ford Escape
1,264 Great Deals out of 111,659 listings starting at $1,300
Used Ford Focus
526 Great Deals out of 76,045 listings starting at $800
Used Ford Crown Victoria
5 Great Deals out of 755 listings starting at $2,995
Used Ford Explorer
943 Great Deals out of 71,545 listings starting at $695
Used Ford Expedition
420 Great Deals out of 22,320 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.