i have a 2003 ford windstar my air cond doesn't blow out the vents only the defrost back vents work

Asked by Jun 07, 2014 at 01:33 PM about the 2003 Ford Windstar

Question type: Maintenance & Repair

2 Answers

69,295

Sounds like you have a disconnected vacuum hose. There will be a vacuum hose that goes from the intake manifold back through the firewall to the control panel on the dash. It's either broken or got disconnected somehow. When the system loses vacuum it defaults to defrost for safety reasons. HTH. -Jim

6 of 6 people found this helpful.

Thank you for the info.

Your Answer

Add photo

Related Questions

Search Ford Windstar Questions

Ford Windstar Experts

#1 JohnBarJB
JohnBarJB
Reputation 560
#2 T_S_T
T_S_T
Reputation 460
#3 Tom Demyan
Tom Demyan
Reputation 400
View All

Related Models For Sale

Used Ford Freestar
609 listings starting at $1,998
Used Dodge Grand Caravan
161 Great Deals out of 25,653 listings starting at $1,750
Used Honda Odyssey
243 Great Deals out of 21,147 listings starting at $1,250
Used Chrysler Town & Country
220 Great Deals out of 14,066 listings starting at $1,800
Used Ford Explorer
806 Great Deals out of 62,465 listings starting at $495
Used Ford F-150
2,208 Great Deals out of 180,794 listings starting at $1,500
Used Toyota Sienna
237 Great Deals out of 26,785 listings starting at $1,495
Used Ford Escape
1,099 Great Deals out of 84,574 listings starting at $1,495
Used Ford Ranger
182 Great Deals out of 5,533 listings starting at $1,000
Used Dodge Caravan
635 listings starting at $2,777
Used Chrysler Pacifica
44 Great Deals out of 26,624 listings starting at $995
Used Kia Sedona
112 Great Deals out of 8,470 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.