Car won't run right

30

Asked by May 29, 2016 at 02:17 PM about the 1975 Ford Ranchero

Question type: Maintenance & Repair

My 1975 Ford ranchero had a rusty fuel
tank. I replaced the tank and fuel filter. It
starts right up and idles fine. Runs good for
a little while when driving then bogs and
quits. It seems like a dirty fuel line or the
sending unit. Any ideas?

2 Answers

83,465

Most likely you have crud in the fuel pump, I would replace the pump, and replace the fuel filter at the carb. You might consider putting an inline clear gas filter just before the pump in case there is rust breaking away in the stock fuel lines, it will catch it before it damages the new fuel pump. HTH

104,435

I agree. If that don't help then I would also check the needle valve on the carb. Trash could be restricting flow.

Your Answer

Add photo

Related Questions

Search Ford Ranchero Questions

UK Questions

Are you a UK consumer? CarGurus now has a discussion forum in the UK.

Ford Ranchero Experts

#1 MrBlueOval
MrBlueOval
Reputation 190
#2 dandyoun
dandyoun
Reputation 150
#3 Michael Tutty
Michael Tutty
Reputation 120
View All

Related Models For Sale

Used Ford F-150
3,014 Great Deals out of 207,752 listings starting at $1,000
Used Ford Mustang
533 Great Deals out of 42,736 listings starting at $1,699
Used Chevrolet Corvette
284 Great Deals out of 20,515 listings starting at $3,688
Used Ford Bronco
181 listings
Used Ford Torino
38 listings
Used Chevrolet Camaro
400 Great Deals out of 40,630 listings starting at $3,500