Replaced all the sensors now what?

Asked by Jan 17, 2015 at 06:47 PM about the 2003 Ford Crown Victoria

Question type: Maintenance & Repair

Help!  The CEL came on we brought to the repair shop we always use.  It was a temp
sensor, they replaced both temp sensors and the thermostat but not the temp gauge
doesn't go above one block and the CEL is back on.  Looks like a trip to the Ford
dealership but does anyone have any ideas?? Thannks!!  Wiring problem or the gauge
itself?

1 Answer

now the temp gauge doesn't move whoops but the car runs fine.

Your Answer

Ford Crown Victoria Experts

  • #1
    Tracy Hooks
    Reputation
    1,860
  • #2
    Tom Demyan
    Reputation
    1,080
  • #3
    tennisshoes
    Reputation
    750
View All

Related Models For Sale

Used Mercury Grand Marquis
32 Great Deals out of 1,762 listings starting at $1,950
Used Ford Taurus
252 Great Deals out of 16,479 listings starting at $1,850
Used Lincoln Town Car
30 Great Deals out of 1,753 listings starting at $1,500
Used Ford Mustang
729 Great Deals out of 38,316 listings starting at $895
Used Chevrolet Impala
516 Great Deals out of 33,923 listings starting at $950
Used Ford Explorer
856 Great Deals out of 63,388 listings starting at $995
Used Ford F-150
2,317 Great Deals out of 183,061 listings starting at $1,000
Used Chevrolet Tahoe
652 Great Deals out of 39,510 listings starting at $1,000
Used Chevrolet Camaro
418 Great Deals out of 30,790 listings starting at $3,550
Used Honda Accord
1,112 Great Deals out of 61,914 listings starting at $999

Used Cars For Sale

2011 Ford Crown Victoria For Sale
3 Great Deals out of 156 listings starting at $4,950
2007 Ford Crown Victoria For Sale
107 listings starting at $2,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.