I have a 1982 280ZX non turbo. My car cuts off after 15 minutes of running. If i wait 15 minutes it starts right up and runs like a champ again.

Asked by Sep 28, 2014 at 10:43 AM about the 1982 Nissan 280ZX

Question type: Maintenance & Repair

I've changed distributors, I've changes Ignition coil I've gotten new cables but nothing seems to work.  I've recently tried changing the fuel pump since no gas it getting to the engine during this time.  I've run out of options.  Again it run greats but cuts off after 15 minutes or so.

2 Answers

65,695

May check the fuel relay,but i think you may need to check that new fuel pump,some time,s you get a bad aftermarket one right off the bat.

65,305

Did you change the fuel filter? Did you check for spark at the engine? Also take a look at the check valve at the fuel pump. If they get stuck closed then you won't get any fuel.

Your Answer

Add photo

Related Questions

280ZX

Looking for a Used 280ZX in your area?

CarGurus has thousands of nationwide listings and the tools to find you a great deal.

ZIP:

Search Nissan 280ZX Questions

Nissan 280ZX Experts

#1 enginecreator
enginecreator
Reputation 50
#2 dandyoun
dandyoun
Reputation 40
#3 F_O_R
F_O_R
Reputation 30
View All

Related Models For Sale

Used Nissan 200SX
13 listings
Used Datsun 280ZX
17 listings
Used Chevrolet Corvette
149 Great Deals out of 20,682 listings starting at $3,995
Used Toyota Supra
53 listings starting at $32,500
Used Chevrolet Camaro
244 Great Deals out of 31,183 listings starting at $369
Used Ford Mustang
543 Great Deals out of 45,840 listings starting at $1,999
Used Datsun 280Z
6 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.