Why doesn't my left turn signal work with headlights on?

5

Asked by Nov 24, 2013 at 08:53 PM about the 1967 Ford Galaxie

Question type: Maintenance & Repair

I have a 67 Galaxie HT, 390 automatic.  Left turn signal works fine when lights are off, but
when the headlights or parking lights are on it doesn't work.  Any troubleshooting
suggestions would be appreciated.

1 Answer

yes the chassis ground is not being picked up by the grounding lug...neither is the left turn signal...make the chassis ground the GROUND already...use a wirebrush~

4 of 4 people found this helpful.

Your Answer

Ford Galaxie Experts

  • #1
    MrBlueOval
    Reputation
    570
  • #2
    tennisshoes
    Reputation
    170
  • #3
    Js08016
    Reputation
    130
View All

Related Models For Sale

Used Ford Mustang
709 Great Deals out of 38,398 listings starting at $895
Used Ford Fairlane
82 listings
Used Chevrolet Impala
479 Great Deals out of 33,615 listings starting at $777
Used Ford Torino
35 listings
Used Ford Falcon
34 listings
Used Ford Thunderbird
16 Great Deals out of 1,081 listings starting at $6,950
Used Pontiac GTO
10 Great Deals out of 475 listings starting at $5,995
Used Chevrolet Corvette
290 Great Deals out of 20,736 listings starting at $2,990
Used Dodge Charger
417 Great Deals out of 27,419 listings starting at $2,495
Used Ford Bronco
183 listings
Used Pontiac Firebird
10 Great Deals out of 784 listings starting at $2,500

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.