Why doesn't my left turn signal work with headlights on?

5

Asked by Nov 24, 2013 at 08:53 PM about the 1967 Ford Galaxie

Question type: Maintenance & Repair

I have a 67 Galaxie HT, 390 automatic.  Left turn signal works fine when lights are off, but
when the headlights or parking lights are on it doesn't work.  Any troubleshooting
suggestions would be appreciated.

1 Answer

yes the chassis ground is not being picked up by the grounding lug...neither is the left turn signal...make the chassis ground the GROUND already...use a wirebrush~

4 of 4 people found this helpful.

Your Answer

Add photo

Search Ford Galaxie Questions

Ford Galaxie Experts

#1 MrBlueOval
MrBlueOval
Reputation 530
#2 tennisshoes
tennisshoes
Reputation 150
#3 Js08016
Js08016
Reputation 130
View All

Related Models For Sale

Used Ford Mustang
461 Great Deals out of 45,641 listings starting at $1,999
Used Ford Fairlane
86 listings
Used Ford Thunderbird
19 Great Deals out of 1,069 listings starting at $6,499
Used Ford LTD
21 listings
Used Chevrolet Impala
578 Great Deals out of 31,558 listings starting at $799
Used Ford Torino
26 listings
Used Chevrolet Corvette
121 Great Deals out of 20,599 listings starting at $3,000
Used Ford Falcon
33 listings
Used Ford F-100
149 listings
Used Lincoln Continental
4,475 listings starting at $40,000
Used Pontiac Firebird
10 Great Deals out of 725 listings starting at $3,875
Used Chevrolet Camaro
218 Great Deals out of 30,798 listings starting at $1,217
Used Dodge Dart
181 Great Deals out of 10,589 listings starting at $3,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.