All Car Questions

  • Newest
  • Recently Active
  • Unanswered
Nickie Jonah Andears
0

Stereo

Im trying to install a jensen single din stereo in my 01 eclipse spyder and can get power but no sound from speakers and I got tge den cable plus the dash cable got power no sound

Nail2594
0

My Oil Light Come On Ever Other Day But It'not Low On Oil It Gose Right Bac...

What could be cause it

6 views with 2 answers (last answer 7 hours ago)
japindell
0

Low Beam Lights Bulbs Bust The Same Time And Passenger Side Is Burnt

What would cause both low beam lights to go out same time and the bulbs actually blow and the passenger side is burnt where it plugs into the lightbulb itself.

BigPaul367
5

I Have A 2003 V6 S10, I Have A Chance To Buy A 1998 V6 S10, Both Are 4.3 Li...

Is there a difference in the 1998 4.3 V6 Long Block that would prevent me from using it in my, 4.3 V6, 2003? And if that is so, is it a difference that I can overcome?

bladee
0

93 F150 5.8, 4x4

I have a 93 F 150 4 by 4 it's getting fuel getting spark but not starting what could be the problem I change the coil pack the computer clean the spark plugs just won't start

16 views with 4 answers (last answer 4 hours ago)
bigfue00
0

Brake Puslating

Replace right drive axel bearings on right side new brakes and calipers now when braking just before stop makes loud noise and pulsesate as you stop almost grabbing never happened before repairs i...

16 views with 10 answers (last answer 6 hours ago)
CassyH
0

Ac

My ac quit working we replaced the resister and when we went to replace the wiring harness. The red wire that goes under the dash arked out. My compressor comes on but it won't blow at all. We are...

2 views with 2 answers (last answer 3 hours ago)
ystephen
0

Is This An Alternator Problem?

So, as stated earlier, my '77 Fiat 124 Spider stalled on the freeway at about 70 mph and would only start and run briefly, if it would start at all. After much testing, I thought I had it figured out...

Valerie Coryat
30

Tune Up On 1998 E250 V8 Triton Van

I am going to do my own tune up on my Ford E250 Econoline van because I simply can't afford to pay $450.00 for a mechanic so my question is ...what if anything should I pay close attention to and wh...

23 views with 5 answers (last answer 15 hours ago)
Steven Thompson
0

Car Cranking But Not Starting??

2004 Cadillac deville northstar ,I put 93 gas in it to the top I click it till it came at the to where I could see it and put a Lil bottle of injector cleaner in ,drive home and park,next morning g...

7 views with 3 answers (last answer 17 hours ago)
DEDESIGN
0

Overheating

I have a 2008 chrysler sebring hard top convertible with a 3.5L V6 engine. Had a local mechanic replace the water pump and he Overheated the engine, as there was white smoke coming out the both exh...

GetaHandleOnit
0

2003 Ford F-350 Triton V-10 Coils

Does anyone know which cylinders are #1, 4 and 9 on the 2003 Ford F-350 Triton V-10 ? I need a diagram or picture, there not labeled. I need to change the bad coils (Based on the Code reader info).

10 views with 3 answers (last answer 13 hours ago)
dcain4u
0

2003 Ford F-150 4.6, O2 Shows Bad, Bank 2 Sensor 2, Won't Smog

I have an 03 f-150, Check engine light is on. Replaced o2 sensor, MAF sensor. Clear the CEL, but the first time I kill the truck and start it back, within 2 minutes the CEL comes back on showing ...

3 views with 1 answer (last answer 16 hours ago)
Zodia4
0

I Have A 2001 Oldmobile Bravada Awd With A 4l60e Trans, I Replaced The Pump...

I have a 2001 Oldsmobile Bravada AWD with a 4L60e automatic trans, I have replaced the pump and torque converter and changed the filter and fluid. Does anyone know why it takes 2 to 3 seconds to go in...

5 views with 1 answer (last answer 17 hours ago)
chestero
0

Is $7995 A Good Price For This Jeep

Used 2002 Jeep Wrangler 4WD Sport , Automatic Mileage: 146,777 4x4 6cyl Automatic, air conditioning, Immaculate condition. Clean carfax, runs excellent, no rust, new tires

7 views with 2 answers (last answer 16 hours ago)
Amanda Wolford
0

Car Won't Start

After having my thermostat replaced, my car no longer starts! Is there any obvious reasons why

9 views with 2 answers (last answer 17 hours ago)
Jim Vaughn
0

Temp Gauge In Cold Position And Air Conditioning Does Not Work

Temp gauge stays in cold position. Oil lamp and temp lamp illuminate. When temp gauge briefly shows normal air works fine. Changed temp sensing unit and thermostat. Even though oil lamp lights up ...

Giants10
0

Car Won't Start

Where are the ground straps located on a 2010 Audi A4 Quattro

Batman00
0

V8

Ok, so this is probably gonna sound like a stupid question, but here we go. Lol! I have a 1993 Cutlass Ceria S, it has a 3.3L V6 in it. Now I won't to put a V8 in it. And I know your gonna have to ...

6 views with 3 answers (last answer 7 hours ago)
Heath Johnston
0

Dodge 2500

My 03 ram 2500 the parking lights will not shut off I tryed disconnecting my battery and reconnecting it they came right back on

prev 1 ... 4 5 6 7 8 ... 8668 next

Favorite Topics

Track new questions that interest you

or

Sign in

CarGurus Experts

#1 Tom Demyan
Tom Demyan
Reputation 179,335
#2 FordNut
FordNut
Reputation 127,975
#3 dandyoun
dandyoun
Reputation 91,635
#4 tenspeed
tenspeed
Reputation 81,215
#5 tennisshoes
tennisshoes
Reputation 62,215
View All