All Car Questions

  • Newest
  • Recently Active
  • Unanswered
bambam1963
0

Gauges Not Working 2005 Grand Prix

started car and gauges and signal lights not working

102 views with 1 answer (last answer about a year ago)
FJunkie
5

72 Cutlass Supreme Air Filter

OK so recently ive devoted a lot of time to checking everything and replacing what needs to be replaced in my 72 cutlass. Now i come to the air filter. Generally i see these circular ruffled types o...

19 views with 2 answers (last answer about a year ago)
Newbirth
0

Where Do I Pour The Transmission Fluid At On My Ford 150 Econoline Truck?

129 views with 3 answers (last answer 3 months ago)
jaykaytlc
0

I Changed Calipers And Brake Pads On 2000 Alero But The Tire Still Will No...

i have a 2000 alero we put the car up on jack stands took front tires off then put car in drive and only driver side tire moved we changed the caliper on passenger side and brake pads but still doi...

124 views with 1 answer (last answer about a year ago)
Ian Bailey
10

93 Tempo Turn Signals Not Working

I have a 93 Ford Tempo this morning neither of my turn signals would work. The hazard lights and all other lights work fine but no turn signals. Any advice? Thanks

193 views with 3 answers (last answer about a year ago)
LongTrail
10

2001 Audi A4 1.8t, Cranks But Won't Start. No Communication To Any Control ...

Check engine light does not light when key is in position 2.

451 views with 1 answer (last answer about a year ago)
bigbvee1966
0

I Have A 2012 Dodge Ram 1500 That Will Click But Not Crank On Start Up. Aft...

1,320 views with 10 answers (last answer about a month ago)
jw8501
0

The Heater Switch On My Dash Broke. How Do I Remove And Replace In 1985 Ben...

179 views with 1 answer (last answer about a year ago)
mustangfixer
0

I Have A 1991 Mustang Lx And The Passenger Door Exterior Handle Is Broke Of...

30 views with 1 answer (last answer about a year ago)
sueredds
0

2000 Durango 4 Wheel Drive Plastic Thing In Center Console.

When we put the truck back into 2 wheel a Plastic L shape piece came out. I know someone else had this problem. Don't know what it is called. Do you and Could my husband fix it? I imagine the whole c...

90 views with 5 answers (last answer about a year ago)
Spaddy
0

I Have A 1998 Escort Lx Seadan That Seems To Have Front End Problem.

The car makes a solid clunking noise when I hit bumps.It has new struts, brakes and tires and the noise didn't change. It has also started to shudder when I back out of parking space if I don't give i...

75 views with 1 answer (last answer about a year ago)
Yohai
0

Ford Focus 2003 Wind Noise At High Speeds.

Hi Everyone, I had the windsheild replaced due to a crack. After that, I get a wind noise when I drive above 80 km/h. The noise gets much louder as the speed increases. I don't feel any air coming i...

67 views with 2 answers (last answer 10 months ago)
lesmont
0

Where Do The Water Goes In On A 2005 Mercury Mountaineer

122 views with 2 answers (last answer about a year ago)
OJ
7,280

Recommendations

Purchased new F-150 V8 when I retired in 2010. Drive very little. Use full synthetic oil, but only add about 5K miles per year. I always change the oil at 5K, which is 2K less than the recommended ...

37 views with 3 answers (last answer about a year ago)
Tammi Barger
0

When Going Up Hills My 98 Sub Forester Feels Like It Is In Nuetral It Wont...

98 sub forester serms like its in nuetral when i start yo a hill or steep grade

47 views with 1 answer (last answer about a year ago)
ArmyBratBDG
0

Battery Light Flashed 2000 Ford Taurus Engine Stalled And Would Not Restart...

Driving home battery light was on and off several times went to go back to work after lunch Car started fine and made it to thew dollar store and than to a gas station came out and car would not start...

256 views with 2 answers (last answer about a year ago)
GeorgeP
0

I Have A 1998 Tahoe. The Left Rear Turn Signal And Break Light Don't Woolly...

160 views with 1 answer (last answer about a year ago)
Jean Fouch
0

I Have A 2005 Ford Taurus, After Having My Emissions Testing Done, The Car ...

Had emissions testing on Friday, car sounds like it isn't running on full cylinders. It runs, drives fine, I don't see any fuel loss, but I'm averaging 14 miles per gallon, started at 71 and am at 43 ...

27 views with 1 answer (last answer about a year ago)
anthonywilson
15

Can I Take The Thermostat Out To See If The Water Pump Is Working? It Shoul...

1994 jeep.overheating problem

108 views with 1 answer (last answer about a year ago)
davidexplorer12214
0

My Explorer Will Not Shift With Engine Running But Will With Engine Off

my explorer will not shift with engine on but will with engine off both reservoirs were empty so I filled them with fluid but it still doesn't work

41 views with 1 answer (last answer about a year ago)

Favorite Topics

Track new questions that interest you

or

Sign in

Ask a Question

CarGurus Experts

#1 Tom Demyan
Tom Demyan
Reputation 124,875
#2 dandyoun
dandyoun
Reputation 72,275
#3 tenspeed
tenspeed
Reputation 64,655
#4 FordNut
FordNut
Reputation 39,735
#5 tennisshoes
tennisshoes
Reputation 34,395
View All