All Car Questions

  • Newest
  • Recently Active
  • Unanswered
Finbar1959
5

Why Won't The Rear Door Of My 2010 Impala Open?

Appears to be locked

4 views with 1 answer (last answer 4 seconds ago)
footdoggie2008
0

I Have A 92 Ford F-150 Iam Having Trouble With The Back Tank Ok It Leaked S...

got two new tanks on it side works fine but when i switch to back it takes about twenty minutes then truck shakes acts like not getting gas but if u catch it before it dies and switch to side tank it ...

johnD777
0

I Have An Opel Omega 3.2 V6 2002 And I Had On Second Gear And My Friend ...

so then something went wrong and the little engine light lit up on my dash board and my car wasn't able to accelerate at ALL like it was going so slow and whenever i was going slow like about 10 Km/h ...

Adam Albert
0

1993 Civic Running Rich

Hi I have a '93 civic with a b16a2 vtec (out of a 1999 si) anyway I had the car about 4 months now and only driven 20km a month. Yes (twenty km) anyway.. Recently as soon as I start the car I can...

Frannie Osborne
0

2000 Cadillac Deville

Usually on the first drive of the day (though not every day) Our speedomoter goes crazy, jumping back and forth and the transmission slips into neutral. Speed sensors have been replaced and it still...

Andres Barrera
0

I Have A 1991 Chevy Sportside Single Cab With A Z71 Motor Carburetor With 0...

It gots new sparks plug tune and a new battery, it turns on really fast and sounds amazing

Andres Barrera
0

I Have A 1991 Chevy Sportside With A Z71 Motor Carburetor With 0 Miles And ...

It gots new sparks plug tune and a new battery, it turns on really fast and sounds amazing

sledge84
0

Red Light On'dash Won't Go Off Car Won't Start

Transponder keys

2 views with 1 answer (last answer 2 hours ago)
Chris Wheeler
0

1996 Z71 Vortec 350 A / T. Traveling With Cruise Set 70mph. Lights Began...

Want go over 35 but will rev . High rpms but not go. Now dont want to idle. No power. Weak. Has misfire. Is it related. happened all at once.

5 views with 2 answers (last answer 2 hours ago)
79paul79
0

I Have A 63 Galaxie That Ran Today For About 5 Minutes And Then Abruptly Qu...

car was running normal and then just quit, no power to the key,no interior or exterior lights work it;s like someone removed the battery, very strange if anyone can think of anything let me know thank...

7 views with 2 answers (last answer 4 hours ago)
Kanehall
0

Could My Transmission Be Bad Or Is It Something Else?

I have a 1995 dodge ram 1500 4x4 360. When the transmission is cold it will take off but once it warms up it doesn't want to pull off. I can put it in 4high and it will move for a little bit then...

7 views with 3 answers (last answer 4 hours ago)
1 2 3 4 5 ... 5767 next

Favorite Topics

Track new questions that interest you

or

Sign in

Ask a Question

CarGurus Experts

#1 Tom Demyan
Tom Demyan
Reputation 104,205
#2 dandyoun
dandyoun
Reputation 62,935
#3 tenspeed
tenspeed
Reputation 57,185
#4 littlehorn
littlehorn
Reputation 27,595
#5 tennisshoes
tennisshoes
Reputation 26,605
View All