I have a 95 nissan altima. The belt for the compressor starts squeaking when I turn on either the ac or the heat. The heat works fine but the ac isn't running. Any ideas what my problem would be?

moharris13
0

Asked by moharris13 May 13, 2014 at 10:56 PM about the 1995 Nissan Altima GXE

Question type: Maintenance & Repair

I have a 95 nissan altima. The belt for the compressor starts squeaking when I turn on
either the ac or the heat. The heat works fine but the ac isn't running. Any ideas what
my problem would be? I took a look while running the ac and the belt was kinds
jamming. It would not be moving as smoothly as when I had the ac off. When the ac or
heat is off the belt is running like there is no issue. Not sure what other information
might help. But thanks guys.
Moe

1 Answer

tennisshoes
29,725

That sounds like a locked up A/C compressor.

Your Answer

Add photo

Related Questions

Search Nissan Altima Questions

Nissan Altima Experts

#1 Tom Demyan
Tom Demyan
Reputation 800
#2 tenspeed
tenspeed
Reputation 420
#3 Cassie Sapphire
Cassie Sapphire
Reputation 300
View All

Related Models For Sale

Used Subaru Legacy"
208 Great Deals out of 9,105 listings starting at $1,494

Used Cars For Sale

2015 Nissan Altima For Sale
39 Great Deals out of 47,634 listings starting at $15,999
2014 Nissan Altima For Sale
128 Great Deals out of 4,747 listings starting at $13,499
2013 Nissan Altima For Sale
241 Great Deals out of 6,505 listings starting at $10,335
2012 Nissan Altima For Sale
199 Great Deals out of 5,973 listings starting at $8,278
2011 Nissan Altima For Sale
67 Great Deals out of 2,134 listings starting at $6,900