Sign in | Register | My account |

Mercury Mariner Premier 2009 looses power and engine light and tool light comes on

Victor Morales
0

Asked by Victor Feb 29, 2012 at 03:47 PM about the 2009 Mercury Mariner Premier V6

Question type: Maintenance & Repair

As I was driving my Mercury Mariner 2009 it suddenly loss power and (while engine was running) I could not accelarate. Engine light and "tool" light came on. I could not do anything to regain speed (acelarator was dissable) and the only fix was to shut down the engine and re-start. Vehicle will start and work normally (except engine light will stay on) and will do it 20-25 minutes later while driving. Any fix or recommendations?
Note: I took vehicle the day before to do the emission control test required for registration.

4 Answers

get5free
40

Had the exact same issue with a 2010 Mariner. This is the second time to dealership. First time they could not find anything..Second time for the same problem (within a week) they replaced the throttle body module..controls fuel air mixture, So far problem has not re-occurred. Only driven 50 or so miles

4 out of 4 people think this is helpful.
knivn
10

My 09 Mariner did the same thing. It was the battery in my case.

1 out of 1 people think this is helpful.
Scott Jordan
20

Same thing with mine. Dealership replaced the throttle body. Also looks like the government is looking into this as it has been an issue with the escapes and mariners in the 2009-2011 time frame (Google 2009 mariner throttle body). Cost me about $350.

2 out of 2 people think this is helpful.
Debra Brown
0

I just received my notice from Mercury to take mine to the dealer and have the throttle body changed free

Your Answer

Related Questions

Mariner
Looking for a Used Mariner in your area?
CarGurus has 1,372 nationwide Mariner listings starting at $4,300.
ZIP:

Search Mercury Mariner Questions

Mercury Mariner Experts

#1 2022erik
2022erik
Reputation 120
#2 kbro
kbro
Reputation 50
#3 get5free
get5free
Reputation 40
View All

Used Cars For Sale