starts ok runs for 10 minutes then stops running

motormike
0

Asked by motormike Jun 09, 2014 at 03:02 AM about the 1994 Oldsmobile Eighty-Eight Royale 4 Dr LS Sedan

Question type: Maintenance & Repair

From a cold start.. drive for 10 minutes and then the car will stop running while in gear
and moving.   Has done this three times...stopped in the exact same location -3.8
miles from home.   May or may not start and run ok after stopping.  Replaced
Camshaft position sensor and I think the dealer that sold me the car replaced the mass
air flow sensor??? When I test drove the car it had already been warmed up and it ran
just  fine.  My Mechanic has difficulty communicating with the ECM.  Could the ECM
cause this or the crank position sensor.  Had to park the car ..too dangerous to drive.
Car has 116000 miles on it. Thanks Mike in AZ

1 Answer

SCShae
30

I've had my 1995 Olds 88 for awhile and it has done pretty much the same thing. The problem with mine was the spark plugs AND ignition coils. Change them all along with plug wires. If it continues it could be fuel system or filters or an electrical short. Hope this helps.

1 out of 1 people think this is helpful.
Best Answer

Your Answer

Related Questions

  • Can a bad key cause?...

    Oldsmobile 88 1992 3.8L Eng. Okay, so I was driving down the road when my car completely shut off,all the warning lights came on, the brake pedal became rigid, and I lost my power steering. I managed...

    1992 Oldsmobile Eighty-Eight Royale 4 Dr LS Sedan

    -

    Maintenance & Repair

  • How to reset theft deterrant system module so my car will start 4 answers

    Went to pet store, came back out & wouldnt start. Power to everything like windows, radio, lights- but nothing happened when i turned key. No crank, no clicking...nothing. Extremely hot outside, ...

    1993 Oldsmobile Eighty-Eight Royale 4 Dr STD Sedan

    -

    Maintenance & Repair

  • My 88 royale wont start 7 answers

    Ok..... I had troubles with this car a month ago not starting... It turned out to be the fuel pump. It had been running perfectly until this afternoon... It would not start... The battery is fine, as...

    1995 Oldsmobile Eighty-Eight Royale

    -

    Maintenance & Repair

  • just drove the car home a few days ago, with no trouble at all, but now it wont start... 1 answer

    I just purchased a 1991 Olds 88 earlier this week, and drove it home the day i bought it with no trouble. But I came out the next day and tried to start it, and then engine would turn and turn and t...

    1991 Oldsmobile Eighty-Eight Royale 4 Dr Brougham Sedan

    -

    Maintenance & Repair

  • Car starts, runs great, shut it off for 15 minutes and then won't even turn over to start again. 6 answers

    I have a oldsmobile Cutless supreme 1989 in near perfect condition. It runs great, I'll run all over town shopping, shut if off, gone 15 minutes, start up, repeat about 5 times. About the 5th time a...

    1989 Oldsmobile Cutlass Supreme

    -

    Maintenance & Repair

Search Oldsmobile Eighty-Eight Royale Questions

Oldsmobile Eighty-Eight Royale Experts

#1 Michael Urbanski
Michael Urbanski
Reputation 120
#2 John Saffrahn
John Saffrahn
Reputation 100
#3 southernpride69
southernpride69
Reputation 50
View All

Related Models For Sale

Used Oldsmobile Eighty-Eight"
156 listings starting at $895