92 silverado not charging after new alternator and battery

mboudre5
70

Asked by mboudre5 Jan 29, 2013 at 01:36 AM about the 1992 Chevrolet C/K 1500 Ext. Cab 6.5-ft. Bed 2WD

Question type: Maintenance & Repair

6 Answers

7jimmy7
12,515

maby it is charging,how do you know ,by the red dash light ,maby?? while running disconnect one bat, wire . if stalls out ,no charge if still running its getting power from alt. to run everything from the alt, may be harness wire break from alt to bat likely in ing. switch, jiggle key while running,just guessing but i am good at this stuff at least my dog agrees

3 out of 3 people think this is helpful.
DavidH25
Not Active

It is not impossible for your new alternator, or more likely the built in regulator, is bad. That happens. The '92's did not have an external regulator, and check all connections, especially battery terminals

5 out of 5 people think this is helpful.
mboudre5
70

Thanks David, Second alternator New not rebiuld and same results. Meter shows 12.75 vdc @battery and 13.8v when running no load. Connections @battery cleaned. Amp guage always showing less than 11v Charging should show more than a mere 13.8 shouldn't it.????Also have Brand New Interstate megatron. I just don't know???

6 out of 6 people think this is helpful.
mboudre5
70

7Jimmy7, Thanks, Alternator will run truck with battery disconnected but its showing a discharge @ amp guage inside?? no light. connections were cleaned @ battery.

1 out of 1 people think this is helpful.
DavidH25
Not Active

13.8 is well within what is should be putting out, it's fine. While charging the amperage will go up, not voltage. Under a full load charging a battery depending on what the alternator is rated, could be as high as 60 amps or more, but voltage remains constant

3 out of 3 people think this is helpful.
Best Answer
danielpalmer
0

would the starter make a battery go bad do i just replaced the battery and i had it checked and it said my battery was bad so i had the starter checked to and it was bad and now my truck wont start without it being jumped but my volts on my guage says over 14 volts and then when i turn my heater on it droppes to 11 volts what would cause this problem i just dont want to replace parts after parts i keep thinking its the alternator please help me im getting frusterated with it i never had a problem like this til i got this truck

Your Answer

Add photo

Related Questions

C/K 1500
Looking for a Used C/K 1500 in your area?
CarGurus has 984 nationwide C/K 1500 listings starting at $2,975.
ZIP:

Search Chevrolet C/K 1500 Questions

Chevrolet C/K 1500 Experts

#1 John Saffrahn
John Saffrahn
Reputation 1,370
#2 Andrew Olsen
Andrew Olsen
Reputation 780
#3 dandyoun
dandyoun
Reputation 400
View All