My 99 chrysler town and country is idle to high after i had the spark plugs changed and i had a full diagnostics done on the van everything checked out so what can be the problem

cureaux31
0

Asked by cureaux31 Mar 26, 2013 at 01:35 PM about the 1999 Chrysler Town & Country LXi

Question type: Maintenance & Repair

3 Answers

tennisshoes
17,915

Sounds like you have a vacuum leak, possibly a cracked hose or connection. Did they clean the throttle plate?

Best Answer
cureaux31
0

We changed the hose that was connected to the engine the throttle plate i don't think they cleaned and as for the hose that was replaced it broke when they removed the cover to the engine to get to the other spark plugs so i replaced it then i was told that the covering to the engine wasn't tight the way it suppose to be and the gasket that suppose ti be there ti keep air from getting in had broke and air was getting in and that's why its idle to high so i went and bought the part

cureaux31
0

It might be a leak i don't know

Your Answer

Related Questions

  • 2001 Chrysler town and country will not start 34 answers

    The van was idling so low it vibrated the van, but running well other than the idling issue so I shut it down to do the repairs, so I replaced the spark plugs, the spark plug wires,ignition coil pack,...

    2001 Chrysler Town & Country Limited

    -

    Maintenance & Repair

  • Our 2012 Chrysler Town & Country has a misfire on cylinder 6. What should we do? 10 answers

    2012 Chrysler Town & Country 3.6 L VVT 41,200 miles Check engine light on constantly

    Chrysler Town & Country

    -

    Maintenance & Repair

  • 99 Chyrsler Town & Country won't start, why? 3 answers

    I Have a 99 Chrysler Town & Country. It has been running fine came home other and turned it off as normal and when I went to crank it up the next morning acted as if it wanted to start but didn't. If ...

    1999 Chrysler Town & Country Limited

    -

    Maintenance & Repair

  • 2010 Chrysler Town and Country turn signal not working 2 answers

    I have a 2010 Chrysler Town and Country van. The rear passenger turn signal does not work. I have replaced the bulb, used bulb grease and checked the fuse in the engine compartment. Still not workin...

    2010 Chrysler Town & Country Touring

    -

    Maintenance & Repair

Town & Country
Looking for a Used Town & Country in your area?
CarGurus has 32,649 nationwide Town & Country listings starting at $495.
ZIP:

Search Chrysler Town & Country Questions

Chrysler Town & Country Experts

#1 Tom Demyan
Tom Demyan
Reputation 700
#2 Sereptia Tucker
Sereptia Tucker
Reputation 680
#3 Grinch007
Grinch007
Reputation 570
View All