Sign in | Register | My account |

07 altima 2.5 won't start can't get codes engine light never comes on

RJ2Vau
0

Asked by RJ2Vau May 14, 2013 at 09:27 PM about the 2007 Nissan Altima 2.5 S

Question type: Maintenance & Repair

I have a 07 Altima about 3 weeks ago it shut off going down the road then after hitting the push button start on then off a few times it finally started. It did it again 2 weeks ago and again this week and now it will not start. when I push the button with the brake on the lights on the dash all come on like normal accept the check engine light does not then there is a light ticking noise from the engine compartment about 7 fast ticks then the cooling fans come on. but it does not start. I replaced the crank and cam sensor, load tested battery, checked starter and fuses all ok. any ideas.

2 Answers

kbro
14,215

Man I was gonna say crank or cam sensor. This sounds like a good one for the dealer. Yes they are expensive but they would be better at figuring this out then a local garage.

Carmelo Lopez
10

Check the brake switch. Mine went bad and the car would not start. Everytime you start your car you have to press the brake, this is the reason why you have to press the brake. There is a switch that enables the car to start.

1 out of 1 people think this is helpful.

Your Answer

Related Questions

Search Nissan Altima Questions

Nissan Altima Experts

#1 Tom Demyan
Tom Demyan
Reputation 430
#2 tenspeed
tenspeed
Reputation 330
#3 Cassie Sapphire
Cassie Sapphire
Reputation 110
View All