I just recharged the Freon and replaced all the compressor seals on my Honda Accord 85. But now the revs drop when A/C is turned on. How can I solve this?

HonditaAzul
0

Asked by HonditaAzul Oct 09, 2013 at 01:24 AM about the 1985 Honda Accord Base Sedan

Question type: Maintenance & Repair

The compressor seals were replaced, the evaporator was cleaned, freon gas was
recharged, but now the revs drop when I turn the A/C on, and the engine temperature rises
a lot.

2 Answers

wlogan
1,180

sounds like the electric fan is not comming on and the sensor that automatically speeds the engine when the ac is turned on isn't working.

1 out of 1 people think this is helpful.
HonditaAzul
0

Exactly, the ting is, this model uses a vacuum hose system that is too complex and I dont know where the vacuum pump responsible for speeding the engine is. Anyone?

Your Answer

Add photo

Related Questions

Search Honda Accord Questions

Honda Accord Experts

#1 Tom Demyan
Tom Demyan
Reputation 1,170
#2 lightGear
lightGear
Reputation 1,150
#3 Jonathan Ford
Jonathan Ford
Reputation 980
View All

Related Models For Sale

Used Toyota Camry"
1,601 Great Deals out of 80,610 listings starting at $1,200
Used Honda Civic"
1,033 Great Deals out of 64,636 listings starting at $1,400
Used Toyota Corolla"
1,299 Great Deals out of 53,373 listings starting at $1,988
Used Nissan Maxima"
442 Great Deals out of 14,101 listings starting at $1,800
Used BMW 3 Series"
1,471 Great Deals out of 35,680 listings starting at $1,800
Used Ford Mustang"
530 Great Deals out of 35,458 listings starting at $1,600