Sign in | Register | My account |

battery seems to have a charge but when i crank it over it acts dead. all lights and power inside works just dont have juice to crank it over. tried jumping it for a while checked connections what could it be.

Rick Wilson
0

Asked by Rick Jul 12, 2013 at 10:27 AM about the 2000 Chevrolet Impala Base

Question type: Maintenance & Repair

i have a check engine light on and its been on a while. the battery as acted as if its dying a few times over past 2 weeks but no problems until today. i drove it and went into bank and turned it off and came out and tried to start it. battery sounded like it was dead when i cranked it. so i jumped it for 30 minutes and it wouldnt take a charge. i pulled jumper cables off friends car and tested my battery to see if it had spark and it sparked nicely. yet when i try to crank it over it wont go. no juice. all interior lights and headlights door chime radio power  everything works. what could be wrong? o2 sensor or just battery doesnt have enough juice? please help

1 Answer

Tom Demyan
67,955

Measure the voltage, it might be low. Should be 12.3 or higher. Remove the battery and take to local auto parts store and they can check. The CEL is probbaly a seperate issue, have the codes read as well. The light is on for a reason.

Your Answer

Related Questions

Search Chevrolet Impala Questions

Chevrolet Impala Experts

#1 Danny Wang
Danny Wang
Reputation 760
#2 Tom Demyan
Tom Demyan
Reputation 570
#3 Justin Hatfield
Justin Hatfield
Reputation 490
View All