My A/C fan does not run at all.

Carla Banalez
0

Asked by Carla Aug 25, 2013 at 11:55 AM about the 2001 Mercury Grand Marquis LS

Question type: Maintenance & Repair

I have an 01 grand with auto temp control. I thought the fan motor went out so I replaced it. I checked the fuses and relays all were good. When I drive with the vent on I can feel the cool air coming out of the vents slightly but nothing happens when I try and adjust fan speed. What should I do

1 Answer

Tracy Hooks
12,175

It's quite possible that your old fan motor burned out the switch in your dash. I've seen several that melted the connection on the back of the switch (you have to pull the controls out to see it). There is also a resistor block that can fail but usually, you will at least have High Speed and nothing else.

Your Answer

Add photo

Related Questions

Search Mercury Grand Marquis Questions

Mercury Grand Marquis Experts

#1 Tracy Hooks
Tracy Hooks
Reputation 2,470
#2 kbro
kbro
Reputation 1,220
#3 Kevin Markic
Kevin Markic
Reputation 560
View All

Related Models For Sale

Used Toyota Avalon"
189 Great Deals out of 15,926 listings starting at $2,400
Used Lincoln Town Car"
84 Great Deals out of 2,369 listings starting at $1,499

Used Cars For Sale

2010 Mercury Grand Marquis LS For Sale
4 Great Deals out of 108 listings starting at $10,500
2009 Mercury Grand Marquis LS For Sale
9 Great Deals out of 158 listings starting at $3,999
2008 Mercury Grand Marquis LS For Sale
7 Great Deals out of 176 listings starting at $5,400