My 2000 Lincoln towncar(signature series) a/c suddenly stopped working, no air thru vents not even outside air. fuses//relay all good. I hear the motor kick but no air thru vents????

nitehawke
0

Asked by nitehawke Jun 28, 2012 at 12:45 PM about the 2000 Lincoln Town Car Signature

Question type: Maintenance & Repair

not sure if I am repeating myself here. but I checked fuses and relays. all good. I can here the motor running when I push max air w'the air to come thru vents 1/2 speed. nothing. when I go to just outside air same nothing thru vents.

2 Answers

jvhack
0

Check the blower once more to be sure it's working. Then check the switch that moves the defrost to vent to floor to see if it's getting vacumm to move if not then I would need more info. (replace the fuses to make sure that they ARE good) I have seen a fuse look good when the part you could not see was blowed. So do these things and let me know. I hope it helped!

Russ Gately
10

Or the blower controller, located on the firewall behind the valve cover, near a wiper arm on the passenger side. That was the problem with my car and if you tap it lightly it may jog it back into operation.

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Lincoln Town Car Questions

Lincoln Town Car Experts

#1 Tom Demyan
Tom Demyan
Reputation 820
#2 Tracy Hooks
Tracy Hooks
Reputation 720
#3 kbro
kbro
Reputation 530
View All

Related Models For Sale

Used Audi A6"
145 Great Deals out of 8,392 listings starting at $1,500
Used Toyota Avalon"
209 Great Deals out of 16,045 listings starting at $2,300