Just had the alternator replaced on an otherwise great car. However I noticed prior to the radio and speedometer which zeroed when the electrical problem 1st arose last week, the speedometer would occasionally get stuck at 60km/h and then unstick to 100km/h. Probably 2 different problems. Now this 276000km car has a refurbished alternator but early mornings after sitting through a cold night for several hours, the radio and wipers don't work, until she heats up!?! Any ideas why that happens ...could a relay be responsible for this heat sensitive issue? Please advise

Altimama94
0

Asked by Altimama94 Apr 08, 2007 at 09:59 AM

Question type: Maintenance & Repair

Just had the alternator replaced on an otherwise great car. However I noticed prior to  the radio and speedometer which zeroed when the electrical problem 1st arose last week, the speedometer would occasionally get stuck at 60km/h and then unstick to 100km/h.  Probably 2 different problems. Now this 276000km car has a refurbished alternator but early mornings after sitting through a cold night for several hours, the radio and wipers don't work, until she heats up!?!  Any ideas why that happens ...could a relay be responsible for this heat sensitive issue?  Please advise

1 Answer

LouB
13,020

Hi Altamama. You could very well have two different problems. The speedometer issue sounds like a bad sensor. The radio wiper issue sounds like there could be a fuse/relay panel in the engine compartment that suffers from condensation when the weather conditions are right. These are guesses. Chances are that the service manager at your local Nissan dealer has seen this before and can help. Take a ride by and pick his brain. Good luck!

Your Answer

Add photo

Related Questions

Search Nissan Questions

Nissan Experts

#1 Tom Demyan
Tom Demyan
Reputation 2,880
#2 dandyoun
dandyoun
Reputation 1,540
#3 tenspeed
tenspeed
Reputation 1,400
View All