I have a 68' mustang strait 6.it lags on power wen I press gas pedal why does it not have much power? What can I do to make it better ?faster? Please anyone help me very much appreciated.

Jimmy Vargas
35

Asked by Jimmy Jul 20, 2013 at 08:09 PM

Question type: Maintenance & Repair

Straight 6 ,68'ford mustang coupe, everything seems to work well except torque, when I
bought it , it hasn't moved for couple years years I did complete time up

3 Answers

Tom Demyan
141,705

In that tuneup, did you rebuild and setup the carberator properly? Add new gas since it's been sitting for years?

3 out of 3 people think this is helpful.
Js08016
35,315

In addition to what Tom said check your ignition timing. Check that the vacuum advance for the distributor is working correctly as well as the centrifugal advance mechanism on the distributor. Be sure your new spark plugs are gapped correctly and the correct type. You should be using standard resistor type spark plugs. No platinum, double platinum, or iridium type. Your engine wasn't designed to run on them. HTH. -Jim

1 out of 1 people think this is helpful.
Michael Tutty
5,955

My first bet is the accelerator pump is not working properly. Also, with the I-6, it will not be a power house no matter what you do to or with it.

Your Answer

Add photo

Related Questions

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 102,990
#2 dandyoun
dandyoun
Reputation 63,990
#3 tenspeed
tenspeed
Reputation 52,310
View All