I have a 91 nissan 300zx problem. My wiper motor has a problem. ok so far this is what i've done. changed the climate control,wiper motor,wiper motor amplifier,tested all the powers (POWER ON) but when i connect the motor itself to the wire harness i dont get power. i also checked the fuse and the relay. i even went to a mechanic to get it looked @ but still. the'res no power after i connect the harness on the amplier. pls help me

farrell2210
60

Asked by farrell2210 Apr 11, 2013 at 09:36 AM

Question type: Maintenance & Repair

5 Answers

judge_roy
Not Active

your battery is old. Get a new one clean the terminal clamps 'sparky-fresh' and clean the black 1/0 cable connecting to the chassis and motor, may seem okay, but that guy's gotta pull 300 cold-cranking amps through it. Batteries will lose their ability to receive a charge 10%/year so after ten the battery will no longer be able to accept a charge~ all others will fall into place once solid reliable power is present~

farrell2210
60

I just change my battery :( and got new wire harness along with new engine. Chasis have 150k on it the new swapped engine has 100+k.

7jimmy7
13,865

when you changed the wiper motor ,if another unit was used,test light the connections ,as the feed wires may be rearranged from year to year

farrell2210
60

Connections have all the power high/low but when i connect it to the amplifier it wont give a juice enough to get the wiper motor running :(

7jimmy7
13,865

amplifier blown out? check resistance?

Your Answer

Add photo

Related Questions

  • Engine runs for a short while then quits. 29 answers

    I have a 1977 Dodge Power Wagon with a 360 engine. It starts right up and runs slow or fast for a short while and then stops. If you try to start it again, it turns over but will not start. If yo...

    1977 Dodge Power Wagon

    -

    Maintenance & Repair

  • how to test the windshield wiper motor in 2003 mercury grand marquis LS 5 answers

    just replaced motor, wipers stopped working

    2003 Mercury Grand Marquis LS Ultimate

    -

    Maintenance & Repair

  • Why won`t my wipers won`t work after replacing switch and wiper motor? 7 answers

    While driving last year my wipers came on by themselves in the delay mode (the wiper switch was off).. Called a local mechanic and told him of my problem and he said could be a ground problem or swit...

    2007 Mercury Grand Marquis LS Premium

    -

    Maintenance & Repair

  • 2011 Dodge Ram 1500 Wipers not Working 4 answers

    the wipers stopped working, replaced the switch and the motor fuses are all good any help would be great

    Dodge Ram Pickup 1500

    -

    Maintenance & Repair

  • Windshield wipers 32 answers

    My wipers stopped last week and the next day they started working okay and today they don't work on slow or intermitt and only work on high speed and the washer wiper doesn;t work

    2004 Mercury Grand Marquis LS Ultimate

    -

    Maintenance & Repair

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 93,090
#2 dandyoun
dandyoun
Reputation 59,640
#3 tenspeed
tenspeed
Reputation 49,020
View All