Sign in | Register | My account |

01 vette started fine cut it off and went to start and low oil light was on added 2 quarts and went to start and low oil light was off but still wont start

hood55
0

Asked by hood55 Dec 30, 2012 at 01:24 PM about the Chevrolet Corvette

Question type: Maintenance & Repair

4 Answers

Robert Mitchell
695

what is your vette doing when you turn the key? low oil will not cause a vette to not start, sounds like a wiring issue, typically a ground wire somewhere... check your battery and battery cables, make sure you have gas (seems obvious)... when you turn ur key does the motor turn over or does any noise happen? if battery was fine prior, have your alternator tested... could be a series of things

hood55
0

when i turn the key nothing happens

Muhammad Zaid
825

not even a click of some sort ?

Robert Mitchell
695

i think i've answered a few of your posts since this one... since your battery isnt dead and you have gas, my next guess would be to check some ground wires, fiberglass gives you horrible places for ground wires, and is natorious for causing issues, but since i cant pin point which one specifically to check on, i'm not suggesting you pull the whole car apart.. how many miles are on the vette, when did you get it, what was the weather like outside, has any wiring been done to the car in the past? if all else fails are you throwing a check engine light? if not, i'm not sure a cam sensor would be the place to start

Your Answer

Related Questions

Corvette
Looking for a Used Corvette in your area?
CarGurus has 8,933 nationwide Corvette listings starting at $3,500.
ZIP:

Search Chevrolet Corvette Questions

Chevrolet Corvette Experts

#1 carGrrl
carGrrl
Reputation 810
#2 Tom Demyan
Tom Demyan
Reputation 570
#3 littlehorn
littlehorn
Reputation 510
View All