no response for temp gauge but the light is on

JfdiscII
55

Asked by JfdiscII Mar 14, 2013 at 09:43 AM about the 2003 Land Rover Discovery

Question type: Maintenance & Repair

no response for temp gauge but the light is on and when you starts the gauge will cycle -- did blow a
hose and repalced that and the thermostat

4 Answers

yawtee
5

change the hose again

JfdiscII
55

hose is good -- do you think i have a air pocket

tenspeed
64,315

If there is an air pocket, that could do it. Bleed out the air. If the gauge is still out, check the sending unit with a meter. It provides the ground connection for the gauge. If you ground the gauge wire, the gauge should read full scale (hot).

JfdiscII
55

i fixed it -- i added more fluid with the engine running for about five min - then disconnected the battery and all lights went off and gauges started working - still hear a little gurgle in heater core but that should go away in a few long drives -- also played with the temp sensor maybe that did some thing as well

Your Answer

Add photo

Related Questions

Discovery
Looking for a Used Discovery in your area?
CarGurus has 221 nationwide Discovery listings starting at $3,995.
ZIP:

Search Land Rover Discovery Questions

Land Rover Discovery Experts

#1 Simon Briggs
Simon Briggs
Reputation 220
#2 Matt Mankinen
Matt Mankinen
Reputation 200
#3 chassy
chassy
Reputation 160
View All

Related Models For Sale

Used Land Rover Range Rover"
137 Great Deals out of 3,013 listings starting at $2,900
Used Land Rover Discovery Series II"
94 listings starting at $2,150
Used Land Rover Freelander"
112 listings starting at $2,999
Used Jeep Wrangler"
901 Great Deals out of 52,575 listings starting at $3,495
Used Toyota 4Runner"
311 Great Deals out of 9,725 listings starting at $1,595
Used Jeep Grand Cherokee"
1,288 Great Deals out of 55,372 listings starting at $1,488
Used Toyota Land Cruiser"
26 Great Deals out of 935 listings starting at $4,398
Used Ford Explorer"
1,017 Great Deals out of 47,827 listings starting at $1,495