The AWD Lock warning light came on I have a 2005 Mercury Mountaineer

JJJJJBBBBB
10

Asked by JJJJJBBBBB Dec 14, 2011 at 09:45 PM about the 2005 Mercury Mountaineer

Question type: Maintenance & Repair

4 Answers

papa
Not Active

could just be a bad sensor or dirty.

JJJJJBBBBB
10

I thought that could be the case but once I made a right hand turn there was a rubbing sound I believe from the front passenger side, I didn't here the same sound when making a left hand turn.

1 out of 1 people think this is helpful.
papa
Not Active

that could have just been a tire rubbing while turning.still say bad or dirty sensor is the problem.

1 out of 1 people think this is helpful.
Jphill
0

Sounds like a wheel bearing going bad.

Your Answer

Add photo

Related Questions

Mountaineer
Looking for a Used Mountaineer in your area?
CarGurus has 1,770 nationwide Mountaineer listings starting at $1,705.
ZIP:

Search Mercury Mountaineer Questions

Mercury Mountaineer Experts

#1 kbro
kbro
Reputation 390
#2 Tom Demyan
Tom Demyan
Reputation 240
#3 tennisshoes
tennisshoes
Reputation 120
View All

Related Models For Sale

Used Ford Explorer"
552 Great Deals out of 51,106 listings starting at $950
Used Saturn VUE"
96 Great Deals out of 2,757 listings starting at $1,561

Used Cars For Sale

2010 Mercury Mountaineer For Sale
8 Great Deals out of 116 listings starting at $9,996
2009 Mercury Mountaineer For Sale
25 listings starting at $9,950
2008 Mercury Mountaineer For Sale
6 Great Deals out of 165 listings starting at $5,999
2007 Mercury Mountaineer For Sale
11 Great Deals out of 249 listings starting at $5,900
2006 Mercury Mountaineer For Sale
11 Great Deals out of 212 listings starting at $3,998