Sign in | Register | My account |

gas pedal not functioning

gone2fish
0

Asked by gone2fish Mar 06, 2013 at 11:43 AM about the 2004 Lexus RX 330

Question type: Maintenance & Repair

gas pedal seems to be disconnected car will not accelerate over 1700 rpm

6 Answers

kbro
14,135

if the engine revs at all when you press the pedal than its not disconnected. you have another issue. sounds like it either cant get enough air in the engine or enough out. check to see if you intake is restricted or the exhaust is restricted

1 out of 1 people think this is helpful.
DavidH25
Not Active

You are possibly in "limp mode" Transmission fault detected. "limp" to the parts house and get the fault codes and bring them back here, one of us will be happy to help

1 out of 1 people think this is helpful.
DavidH25
Not Active

Any lights on dash lit?

judge_roy
Not Active

...hey, there's a problem with the TPS....test it to see if the output is okay or ignored.

1 out of 1 people think this is helpful.
DavidH25
Not Active

TPS meaning Throttle position Sensor, not to be confused with Tire Pressure Sensor

2 out of 2 people think this is helpful.
judge_roy
Not Active

yes H25. seems quite reasonable...I mean where man interacts with machine, WILL be problems....'tis the nature of the beast- regardez:

2 out of 2 people think this is helpful.

Your Answer

Related Questions

RX 330
Looking for a Used RX 330 in your area?
CarGurus has 1,092 nationwide RX 330 listings starting at $8,300.
ZIP:

Search Lexus RX 330 Questions

Lexus RX 330 Experts

#1 Dariele Auteri
Dariele Auteri
Reputation 220
#2 Deepakgandhi
Deepakgandhi
Reputation 90
#3 Bobby O'Connell
Bobby O'Connell
Reputation 80
View All

Used Cars For Sale