Sign in | Register | My account |

Is My Fuel Pump Dying?

Quinton Morse
35

Asked by Quinton Nov 18, 2011 at 09:44 PM about the 1985 Chevrolet C/K 10

Question type: Maintenance & Repair

I have a 1985 Chevy K10 pickup with a 305 TPI from a 1986 Camaro. I think I need a new fuel pump. It'll hesitate when I start it,
takes like 5 seconds to start, normally it fires right up. When you turn the key to the on position the whine the fuel pump makes
seems alot louder then it normally does. It'll drive but once I get past 40MPH it loses power and bogs down and it will try stalling
on me, just like its starving for fuel. Sometimes it'll happen when i'm only going 25MPH. Thought it was the fuel pump so i replaced
it but still no luck. It has an electric fuel pump located in the tank. Anyone else think its my fuel pump starting to go or could it be
something else? Havent had a chance to do a pump pressure test yet.

3 Answers

Michael McGrail
4,525

I would check your fuel pressure.. Kinda stupid question here... When did you last change the fuel filter? Also.. You are using two fuel pumps???

Quinton Morse
35

changed the filter last week. the truck was originally set up for 2 tanks but the passenger side tank was removed 3 or 4 years ago

natalie000
75

I have a 2002 maxima and had the same problem...not sure if it applies to a 1985 but the problem was the MAF sensor. Hope this helps

Your Answer

Related Questions

C/K 10
Looking for a Used C/K 10 in your area?
CarGurus has 41 nationwide C/K 10 listings starting at $3,200.
ZIP:

Search Chevrolet C/K 10 Questions

Chevrolet C/K 10 Experts

#1 7jimmy7
7jimmy7
Reputation 30
#2 Michael Mierzejewski
Michael Mierzejewski
Reputation 20
#2 Jonathan Furse
Jonathan Furse
Reputation 20
View All