2009 A4 -- having problems with AMI/iPod system

Christina Ross
35

Asked by Christina Jul 07, 2009 at 10:49 AM about the 2009 Audi A4

Question type: Maintenance & Repair

Is anyone else having a problem with the integrated AMI/iPod system? My 160GB iPod Classic worked for the first week I had the car; now the car says that the attached device cannot be read. (The only thing I did was buy a new 32GB iPod Touch and plug it into the system in order to charge the battery.) The iPod Classic works perfectly otherwise, both stand-alone and attached to my computer. Apple is proving to be the biggest bunch of A-holes to try to deal with; Audi is hitting a dead end. The geek in me says it's a software issue, but I cannot find anything anywhere to substantiate my claim. I would like Audi to simply replace the entire AMI system, but I understand their reluctance to do that. On the other hand, this is my 4th A4 so I should get some credit for brand loyalty.

Any insight or assistance will be greatly appreciated.

13 Answers

Blindrage
0

Have you tried attaching it to another vehicle on the Audi showroom floor? That will at least tell you if the problem is on the IPod or Audi end of things.

Christina Ross
35

Brought iPod to the dealership and connected it to owner's personal car (Q7) -> wouldn't read. Connected it to brand new Q5 -> not only wouldn't read, but iPod wouldn't even register that it was connected. Service techs downloaded info from car and are supposed to be looking into matter further. You have to understand that the iPod functions perfectly both stand-alone and while connected to my computer. It has never been dropped or otherwise abused. I have never had to reset it. It does have the most current software installed. And it DID work for a few days when I initially got the car!! I am finding that certain accessories are not compatible with the new iPod Touch, but when those accessories are replaced with newer ones, they DO work with the older iPods (Nano, Classic). And Apple still has their collective heads up their collective asses on this one.

1 out of 1 people think this is helpful.
VictoriainSC
0

I found this site while researching the same problem with my new iPod touch and my 2008 A6 Avant. The AMI apparently doesn't recognize it, as the screen shows "no device attached" (though it did, once in numerous tries, briefly indicate that the system was initializing the device ... then back to original message.) Please post back if you find an answer and I'll do the same. Your experience isn't encouraging, however!

jetskibill
0

I have a new shape Audi A4 Avant. For 2 months my ipod/ami was fine and from then it has given problems. For no apparent reason the music goes off line and all you can hear is cracling and interference, sometimes the left hand or right hand channels go down and its just like you pulled the ariel out of a radio. This problem occurs everyday at no regular interval and is not a connection problem. It has no faults diagnosed by Audi engine management tests so they are stumped. They want to replace the ami unit in the glovebox but the part has been deferred on back order 5 times now and i have been waiting 6 weeks. I am thinking of returning the car. I am confident that the ami have problems with the manufacturer as in the build of the part but it would be quicker to replace the car rather than wait for the replacement part! Audi will not tell you that there are any problems with the part as it is not in their interest to do so. Very annoying and if i were German it would have been taken back weeks ago

Kolademan
0

I read somewhere that AMI dosn't work well with the I pod touch..

Christina Ross
35

Update on original situation.... No one at Audi knows what to do. The dealership is actually willing to replace my iPod Classic, but I'm a little hesitant on that because Apple no longer makes the 160GB; the largest capacity is only 120GB. The next step is that I am going to re-format my iPod and reload my music/content (or at least some of the music/content) and see if that fixes the problem. I'll let you know what happens.

1 out of 1 people think this is helpful.
cmora
0

I have a 2009 Audi A4 and I am on my 3rd AMI cable which is about to get replaced with a 4th cable. I have had the car since November. Different symptons each time (no bass, no sound, stays "connecting", etc...). But you put a new cable in and it works perfectly. I am also having an issue where the song playing is not what is being displayed on the Audi screen. I think that might be a iPhone OS 3.0 issue. Try getting the cable replace and see if fixes the issue.

jetskibill
0

Hi My A4 recognises my i-touch ok so ask the dealership if the software within the car needs updating and i am sure that will give you the fix you need

auditech16
70

make sure your ipod cable is the latest which has a blue end.i know for a fact that when you connect to itunes they change the ipod firmware without you knowing.also there is a software update for the mmi system/phone module.this also causes problems.good luck!

1 out of 1 people think this is helpful.
shonng22
0

Just got my A4 2 days ago. The AMI worked for two days. Now, not only won't it recognize my 160GB iPod Classic but it also fried my iPod. Can't even get it on anymore. This is my second A4 and the last one had similar issues. German engineering isn't what it used to be. But the car looks cool, so I'm happy.

lp1955
10

Christina - I don't have an answer for you, but I can tell you I'm having similar problems with my '08 A4. The system "reloads" about every 15 seconds and songs are interrupted all the time. I'm looking to see if there's a way or some sort of override, so that I can control the songs being played by using the iPod itself - having to go through the A4 stereo system is not working! Good luck!

1 out of 1 people think this is helpful.
jensyl
45

same issue as others above but my ipad2 connects and plays music but my iphone 4s does not anymore.....it used to work till a few days ago.

2 out of 2 people think this is helpful.
malexand7
30

Did anybody ever find an answer to this. My 160GB ipod classic worked fine in '13 Q7 for 5 months and no the AMI will not recognize it. Dealer and audio specialist can't figure out the issue. ipod plays perfectly in '06 Infiniti M45 and other vehicles. I think it is just an Audi AMI issue with the ipod classic. My son's 16 GB ipod works great in the Q7. Audio specialist said the AMI struggles reading bulk data and suspects that it chokes on the 160 GB, but he can't figure out why it worked for 5 months.

3 out of 3 people think this is helpful.

Your Answer

Add photo

Related Questions

  • my audi A4 quattro is shaking while on park.Why? 11 answers

    I have an Audi2001 A4 quattro 2.8,Why is it trembling,and shaking while park.

    2001 Audi A4 2.8 Quattro

    -

    Maintenance & Repair

  • 2005 audi a4 1.8T common problems? 1 answer

    I've been looking for an a4 for a while now and I finally found one that I'll most likely buy. But before I do I just wanted to know some common problems that I should be weary of. I know how exp...

    2005 Audi A4 1.8T

    -

    Maintenance & Repair

  • audi a4 has bad radio reception 4 answers

    hi ive got an a4 (my 02)its got a sony head unit, but i've got poor radio reception, is there a wire in the car loom that might not be connected that powers the screen areil?

    2002 Audi A4

    -

    Maintenance & Repair

  • 04 Audi A4 cab ESP intermittently on while driving. Is there a recall for this 3 answers

    04 Audi A4 Cab. ESP driving me nuts. Light intermitentlly comes on, goes off when I restart the car. Mechanic says just reset it. Will this hurt the components of the system?

    2004 Audi A4 3.0 Convertible

    -

    Maintenance & Repair

  • 1999 Audi A4 1.8T Quattro Sedan Questions 2 answers

    I have a 1999 audi a4 1.8 quattro sedan and the sound system is horrible because when I connect my Ipod to it through the casette or play anything off the radio it is hard to have it loud because the ...

    1999 Audi A4 1.8T Quattro

    -

    Shopping & Pricing

A4
Looking for a Used A4 in your area?
CarGurus has 10,639 nationwide A4 listings starting at $1,800.
ZIP:

Search Audi A4 Questions

Audi A4 Experts

#1 Deathjam4
Deathjam4
Reputation 460
#2 David Gross
David Gross
Reputation 210
#3 mlp
mlp
Reputation 190
View All

Related Models For Sale

Used BMW 3 Series"
1,214 Great Deals out of 37,861 listings starting at $1,200
Used Audi A6"
107 Great Deals out of 8,024 listings starting at $1,999
Used Audi A5"
85 Great Deals out of 2,801 listings starting at $17,950
Used Audi S4"
33 Great Deals out of 1,584 listings starting at $4,200
Used Mercedes-Benz C-Class"
651 Great Deals out of 21,645 listings starting at $2,850
Used Audi A3"
44 Great Deals out of 7,307 listings starting at $3,988
Used BMW 5 Series"
409 Great Deals out of 15,221 listings starting at $1,500
Used Audi A4 Avant"
27 Great Deals out of 353 listings starting at $5,498
Used Audi A8"
44 Great Deals out of 2,626 listings starting at $1,900
Used Honda Accord"
1,202 Great Deals out of 66,799 listings starting at $1,000
Used Acura TL"
261 Great Deals out of 6,860 listings starting at $2,300
Used Lexus IS 250"
224 Great Deals out of 8,722 listings starting at $7,777
Used Volkswagen Jetta"
1,056 Great Deals out of 38,274 listings starting at $1,298
Used Audi Q5"
65 Great Deals out of 6,843 listings starting at $16,990
Used Infiniti G37"
265 Great Deals out of 6,087 listings starting at $11,488

Used Cars For Sale

2015 Audi A4 For Sale
3,853 listings
2014 Audi A4 For Sale
24 Great Deals out of 1,097 listings starting at $26,991
2013 Audi A4 For Sale
16 Great Deals out of 398 listings starting at $21,295
2012 Audi A4 For Sale
32 Great Deals out of 703 listings starting at $17,944
2011 Audi A4 For Sale
54 Great Deals out of 849 listings starting at $14,899